import re
regex = re.compile(r"^(?<object>[-\w]+)/([-\w]+)$")
test_str = "Abc-def/edg"
subst = "$2 - / - $1"
result = regex.sub(subst, test_str)
if result:
print(result)