use strict;
my $str = 'Abc-def/edg';
my $regex = qr~^(?<object>[-\w]+)/([-\w]+)$~p;
my $subst = '$2 - / - $1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";