re = /^(?<object>[-\w]+)\/([-\w]+)$/
str = 'Abc-def/edg'
subst = '$2 - / - $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result