const regex = new RegExp('^(?<object>[-\\w]+)/([-\\w]+)$', 'g')
const str = `Abc-def/edg`;
const subst = `$2 - / - $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);