$re = '~^(?<object>[-\w]+)/([-\w]+)$~';
$str = 'Abc-def/edg';
$subst = "$2 - / - $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;