using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<object>[-\w]+)/([-\w]+)$";
string substitution = @"$2 - / - $1";
string input = @"Abc-def/edg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}