# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<span id=pink>.*?<\\/span>(.*?)(?=<span|$)//gs;t' <<< "<span id=pink>some short text</span>
more text that can be a few lines
<span id=pink>again a short text</span>
More text that's abiding the same logic
<span id=pink>Repeat</span>...(more of these)"