# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span id=pink>.*?<\/span>(.*?)(?=<span|$)"
test_str = ("<span id=pink>some short text</span>\n"
" more text that can be a few lines\n"
" <span id=pink>again a short text</span> \n"
" More text that's abiding the same logic\n"
"<span id=pink>Repeat</span>...(more of these)")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.