import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span id=pink>.*?<\\/span>(.*?)(?=<span|$)";
final String string = "<span id=pink>some short text</span>\n"
+ " more text that can be a few lines\n"
+ " <span id=pink>again a short text</span> \n"
+ " More text that's abiding the same logic\n"
+ "<span id=pink>Repeat</span>...(more of these)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}