const regex = /<span id=pink>.*?<\/span>(.*?)(?=<span|$)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span id=pink>.*?<\\\/span>(.*?)(?=<span|$)', 'gs')
const str = `<span id=pink>some short text</span>
more text that can be a few lines
<span id=pink>again a short text</span>
More text that's abiding the same logic
<span id=pink>Repeat</span>...(more of these)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);