$re = '/<span id=pink>.*?<\/span>(.*?)(?=<span|$)/s';
$str = '<span id=pink>some short text</span>
more text that can be a few lines
<span id=pink>again a short text</span>
More text that\'s abiding the same logic
<span id=pink>Repeat</span>...(more of these)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;