use strict;
my $str = '<span id=pink>some short text</span>
more text that can be a few lines
<span id=pink>again a short text</span>
More text that\'s abiding the same logic
<span id=pink>Repeat</span>...(more of these)';
my $regex = qr/<span id=pink>.*?<\/span>(.*?)(?=<span|$)/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";