#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<span id=pink>.*?<\/span>(.*?)(?=<span|$)"
Local $sString = "<span id=pink>some short text</span>" & @CRLF & _
" more text that can be a few lines" & @CRLF & _
" <span id=pink>again a short text</span> " & @CRLF & _
" More text that's abiding the same logic" & @CRLF & _
"<span id=pink>Repeat</span>...(more of these)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)