using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span id=pink>.*?<\/span>(.*?)(?=<span|$)";
string substitution = @"";
string input = @"<span id=pink>some short text</span>
more text that can be a few lines
<span id=pink>again a short text</span>
More text that's abiding the same logic
<span id=pink>Repeat</span>...(more of these)";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}