re = /<span id=pink>.*?<\/span>(.*?)(?=<span|$)/
str = '<span id=pink>some short text</span>
more text that can be a few lines
<span id=pink>again a short text</span>
More text that\'s abiding the same logic
<span id=pink>Repeat</span>...(more of these)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result