# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z]+:)(.*?)([a-z]+:)(.*)/\1 "redacted"\n\3 "redacted"/gsi;t' <<< "From: Tom novy <AJames@onmicrosoft.com>
To: \"mithrandir@wttom.onmicrosoft.com\""