// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?si)([a-z]+:)(.*?)([a-z]+:)(.*)").unwrap();
let string = "From: Tom novy <AJames@onmicrosoft.com>
To: \"mithrandir@wttom.onmicrosoft.com\"";
let substitution = "\\1 \"redacted\"\\n\\3 \"redacted\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}