package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)([a-z]+:)(.*?)([a-z]+:)(.*)`)
var str = `From: Tom novy <AJames@onmicrosoft.com>
To: "mithrandir@wttom.onmicrosoft.com"`
var substitution = "\1 "redacted"\n\3 "redacted""
fmt.Println(re.ReplaceAllString(str, substitution))
}