use strict;
my $str = 'From: Tom novy <AJames@onmicrosoft.com>
To: "mithrandir@wttom.onmicrosoft.com"';
my $regex = qr/([a-z]+:)(.*?)([a-z]+:)(.*)/sip;
my $subst = '\\1 "redacted"\\n\\3 "redacted"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";