const regex = /([a-z]+:)(.*?)([a-z]+:)(.*)/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]+:)(.*?)([a-z]+:)(.*)', 'gsi')
const str = `From: Tom novy <AJames@onmicrosoft.com>
To: "mithrandir@wttom.onmicrosoft.com"`;
const subst = `\1 "redacted"\n\3 "redacted"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);