re = /([a-z]+:)(.*?)([a-z]+:)(.*)/i
str = 'From: Tom novy <AJames@onmicrosoft.com>
To: "mithrandir@wttom.onmicrosoft.com"'
subst = '\\1 "redacted"\\n\\3 "redacted"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result