$re = '/([a-z]+:)(.*?)([a-z]+:)(.*)/si';
$str = 'From: Tom novy <AJames@onmicrosoft.com>
To: "mithrandir@wttom.onmicrosoft.com"';
$subst = "\1 \"redacted\"\n\3 \"redacted\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;