#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?si)([a-z]+:)(.*?)([a-z]+:)(.*)"
Local $sString = "From: Tom novy <AJames@onmicrosoft.com>" & @CRLF & _
"To: "mithrandir@wttom.onmicrosoft.com""
Local $sSubst = "\1 "redacted"\n\3 "redacted""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)