import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]+:)(.*?)([a-z]+:)(.*)";
final String string = "From: Tom novy <AJames@onmicrosoft.com>\n"
+ "To: \"mithrandir@wttom.onmicrosoft.com\"";
final String subst = "\\1 \"redacted\"\\n\\3 \"redacted\"";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}