# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\?php echo \$(.*?)\[(.*?)\];\s*\?>/<?php echo \$$1['$2']; ?>/gm;t' <<< "<?php echo $rsedit[customer_name]; ?>
<?php echo $rsedit[address]; ?>
<?php echo $rsedit[city]; ?>
<?php echo $rsedit[pincode]; ?>
<?php echo $rsedit[contact_no]; ?>
<?php echo $rsedit[email_id]; ?>"