const regex = /<\?php echo \$(.*?)\[(.*?)\];\s*\?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\?php echo \\$(.*?)\\[(.*?)\\];\\s*\\?>', 'gm')
const str = `<?php echo \$rsedit[customer_name]; ?>
<?php echo \$rsedit[address]; ?>
<?php echo \$rsedit[city]; ?>
<?php echo \$rsedit[pincode]; ?>
<?php echo \$rsedit[contact_no]; ?>
<?php echo \$rsedit[email_id]; ?>`;
const subst = `<?php echo \$$1['$2']; ?>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);