use strict;
my $str = '<?php echo $rsedit[customer_name]; ?>
<?php echo $rsedit[address]; ?>
<?php echo $rsedit[city]; ?>
<?php echo $rsedit[pincode]; ?>
<?php echo $rsedit[contact_no]; ?>
<?php echo $rsedit[email_id]; ?>';
my $regex = qr/<\?php echo \$(.*?)\[(.*?)\];\s*\?>/mp;
my $subst = '<?php echo \\$$1[\'$2\']; ?>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";