# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\?php echo \$(.*?)\[(.*?)\];\s*\?>"
test_str = ("<?php echo $rsedit[customer_name]; ?>\n"
"<?php echo $rsedit[address]; ?>\n"
"<?php echo $rsedit[city]; ?>\n"
"<?php echo $rsedit[pincode]; ?>\n"
"<?php echo $rsedit[contact_no]; ?>\n"
"<?php echo $rsedit[email_id]; ?>")
subst = "<?php echo \\$$1['$2']; ?>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.