import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?php echo \\$(.*?)\\[(.*?)\\];\\s*\\?>";
final String string = "<?php echo $rsedit[customer_name]; ?>\n"
+ "<?php echo $rsedit[address]; ?>\n"
+ "<?php echo $rsedit[city]; ?>\n"
+ "<?php echo $rsedit[pincode]; ?>\n"
+ "<?php echo $rsedit[contact_no]; ?>\n"
+ "<?php echo $rsedit[email_id]; ?>";
final String subst = "<?php echo \\$$1['$2']; ?>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}