re = /<\?php echo \$(.*?)\[(.*?)\];\s*\?>/m
str = '<?php echo $rsedit[customer_name]; ?>
<?php echo $rsedit[address]; ?>
<?php echo $rsedit[city]; ?>
<?php echo $rsedit[pincode]; ?>
<?php echo $rsedit[contact_no]; ?>
<?php echo $rsedit[email_id]; ?>'
subst = '<?php echo \\$$1[\'$2\']; ?>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result