#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)"
Local $sString = "<snippet>" & @CRLF & _
"<content><![CDATA[$1_$2" & @CRLF & _
"]]></content>" & @CRLF & _
"<tabTrigger>a1</tabTrigger>" & @CRLF & _
"<description></description>" & @CRLF & _
"<scope>text.tex.latex</scope>" & @CRLF & _
"</snippet>" & @CRLF & _
"" & @CRLF & _
"<snippet>" & @CRLF & _
"<content><![CDATA[$1_$2" & @CRLF & _
"]]></content>" & @CRLF & _
"<tabTrigger>F1</tabTrigger>" & @CRLF & _
"<description></description>" & @CRLF & _
"<scope>text.tex.latex</scope>" & @CRLF & _
"</snippet>"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)