re = /(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)/mi
str = '<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>a1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>
<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>F1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result