import Foundation
let pattern = #"(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>a1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>
<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>F1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)