const regex = /(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<tabTrigger>[a-z])(?=\\d<\\\/tabTrigger>)', 'gmi')
const str = `<snippet>
<content><![CDATA[\$1_\$2
]]></content>
<tabTrigger>a1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>
<snippet>
<content><![CDATA[\$1_\$2
]]></content>
<tabTrigger>F1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);