# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)"
test_str = ("<snippet>\n"
"<content><![CDATA[$1_$2\n"
"]]></content>\n"
"<tabTrigger>a1</tabTrigger>\n"
"<description></description>\n"
"<scope>text.tex.latex</scope>\n"
"</snippet>\n\n"
"<snippet>\n"
"<content><![CDATA[$1_$2\n"
"]]></content>\n"
"<tabTrigger>F1</tabTrigger>\n"
"<description></description>\n"
"<scope>text.tex.latex</scope>\n"
"</snippet>")
subst = "_"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.