use strict;
my $str = '<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>a1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>
<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>F1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>';
my $regex = qr/(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)/mip;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";