$re = '/(?<=<tabTrigger>[a-z])(?=\d<\/tabTrigger>)/mi';
$str = '<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>a1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>
<snippet>
<content><![CDATA[$1_$2
]]></content>
<tabTrigger>F1</tabTrigger>
<description></description>
<scope>text.tex.latex</scope>
</snippet>';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;