import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<tabTrigger>[a-z])(?=\\d<\\/tabTrigger>)";
final String string = "<snippet>\n"
+ "<content><![CDATA[$1_$2\n"
+ "]]></content>\n"
+ "<tabTrigger>a1</tabTrigger>\n"
+ "<description></description>\n"
+ "<scope>text.tex.latex</scope>\n"
+ "</snippet>\n\n"
+ "<snippet>\n"
+ "<content><![CDATA[$1_$2\n"
+ "]]></content>\n"
+ "<tabTrigger>F1</tabTrigger>\n"
+ "<description></description>\n"
+ "<scope>text.tex.latex</scope>\n"
+ "</snippet>";
final String subst = "_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}