# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<pb\/>\n+ +- ?(\d+) ?-/<pb n=\1\/>/gm;t' <<< "<pb/>
- 6-
II faut preparer l'opinion publique et 'habituer A considérer la felon
dont les lois doivent étre faites."