import Foundation
let pattern = #"<pb/>\n+ +- ?(\d+) ?-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<pb/>
- 6-
II faut preparer l'opinion publique et 'habituer A considérer la felon
dont les lois doivent étre faites.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<pb n=\1/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)