re = /<pb\/>\n+ +- ?(\d+) ?-/m
str = '<pb/>
- 6-
II faut preparer l\'opinion publique et \'habituer A considérer la felon
dont les lois doivent étre faites.'
subst = '<pb n=\\1/>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result