use strict;
my $str = '<pb/>
- 6-
II faut preparer l\'opinion publique et \'habituer A considérer la felon
dont les lois doivent étre faites.';
my $regex = qr@<pb/>\n+ +- ?(\d+) ?-@mp;
my $subst = '<pb n=\\1/>';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";