# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<pb/>\n+ +- ?(\d+) ?-"
test_str = ("<pb/>\n\n\n\n\n\n\n"
" - 6-\n"
" II faut preparer l'opinion publique et 'habituer A considérer la felon\n"
" dont les lois doivent étre faites.")
subst = "<pb n=\\1/>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.