package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<pb/>\n+ +- ?(\d+) ?-`)
var str = `<pb/>
- 6-
II faut preparer l'opinion publique et 'habituer A considérer la felon
dont les lois doivent étre faites.`
var substitution = "<pb n=\1/>"
fmt.Println(re.ReplaceAllString(str, substitution))
}