import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<pb/>\\n+ +- ?(\\d+) ?-";
final String string = "<pb/>\n\n\n\n\n\n\n"
+ " - 6-\n"
+ " II faut preparer l'opinion publique et 'habituer A considérer la felon\n"
+ " dont les lois doivent étre faites.";
final String subst = "<pb n=\\1/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}