const regex = new RegExp('<pb/>\\n+ +- ?(\\d+) ?-', 'gm')
const str = `<pb/>
- 6-
II faut preparer l'opinion publique et 'habituer A considérer la felon
dont les lois doivent étre faites.`;
const subst = `<pb n=\1/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);