# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/research\\//\\/research-library\/?report=/gm;t' <<< "/research/the-123s-of-school-choice/
"