#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/research\/"
Local $sString = "/research/the-123s-of-school-choice/" & @CRLF & _
""
Local $sSubst = "\/research-library/?report="
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)