re = /\/research\//m
str = '/research/the-123s-of-school-choice/
'
subst = '\\/research-library/?report='
result = str.gsub(re, subst)
# Print the result of the substitution
puts result