package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/research\/`)
var str = `/research/the-123s-of-school-choice/
`
var substitution = "\/research-library/?report="
fmt.Println(re.ReplaceAllString(str, substitution))
}